Skip to main content

2026년 10월 29일

Internet Engineering Task Force Standards

Note: Horizon Web Client is available with Horizon 8 versions 2412 and later. For Horizon 8 versions 2406 and earlier, Horizon Web Client is called "HTML Access." This documentation page uses the name "Horizon Web Client" to refer to both Horizon Web Client and HTML Access.

Connection Server complies with certain Internet Engineering Task Force (IETF) standards.

  • RFC 5746 Transport Layer Security (TLS) – Renegotiation Indication Extension, also known as secure renegotiation, is activated by default.

    Note: Client-initiated renegotiation is deactivated by default on Connection Servers. To activate, edit registry value [HKLM\SOFTWARE\Omnissa\Horizon\plugins\wsnm\TunnelService\Params]JvmOptions and remove -Djdk.tls.rejectClientInitiatedRenegotiation=true from the string.

  • RFC 6797 HTTP Strict Transport Security (HSTS), also known as transport security, is activated by default. This setting cannot be deactivated.

    Note: For Horizon 2406 and later, you can adjust the header lifetime. It is still set to one year by default, but can be changed to any length by adding hstsMaxAge = 31556926 to locked.properties.

  • RFC 7034 HTTP Header Field X-Frame-Options, also known as counter click-jacking, is activated by default. You can deactivate it by adding the entry x-frame-options=OFF to the file locked.properties. For information about adding properties to the file locked.properties, see Configure HTTP Protection Measures.

    Note: In releases earlier than version 7.2, changing this option did not affect connections to Horizon Web Client.

  • RFC 6454 Origin Checking, which protects against cross-site request forging, is activated by default. You can deactivate it by adding the entry checkOrigin=false to locked.properties. For more information, see Cross-Origin Resource Sharing.

    Note: In earlier releases, this protection was deactivated by default.

이 페이지가 도움이 되었나요?

이 항목에 대한 피드백 보내기

이 항목이 도움이 되었나요?

개인정보나 기밀정보는 입력하지 마세요.

링크를 생성하는 중…